<!DOCTYPE html>
<!--


           .d88888b.             
         .8P"     "9bd888b.      
        .8P     .d8P"   `"988.   
     .8888   .d8P"    ,     98.  
   .8P" 88   8"    .d98b.    88  
  .8P   88   8 .d8P"   "98b. 88  
  88    88   8P"  `"8b.    "98.  
  88.   88   8       8"8b.    88 
   88    "98.8       8   88   "88
    `8b.    "98.,  .d8   88    88
    88 "98b.   .d8P" 8   88   d8"
    88    "98bP"    .8   88 .d8" 
    "8b     `    .d8P"   8888"   
     "88b.,   .d8P"     d8"      
       "9888P98b.     .d8"       
               "988888P"         


  Solve Impossible Problems
  openai.com/jobs


-->
<html lang="en">
<head>
  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-71156606-1"></script>
  <script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());

    gtag('config', 'UA-71156606-1');
  </script>
  <meta charset="utf-8" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />
  <title>Jukebox</title>
  <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
  <link rel="stylesheet" type="text/css" href="/assets/styles/all.css?v=ec60cd2442" />
  
  <script type="text/javascript">document.documentElement.className = 'js';</script>
  <link rel="icon" type="image/svg+xml" href="/assets/images/favicon.svg?v=ec60cd2442">
  <link rel="mask-icon" href="/assets/images/mask-icon.svg?v=ec60cd2442" color="#000000">
  <meta name="description" content="We’re introducing Jukebox, a neural net that generates music, including rudimentary singing, as raw audio in a variety of genres and artist styles." />
    <link rel="icon" href="/favicon.png" type="image/png" />
    <link rel="canonical" href="https://openai.com/blog/jukebox/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    
    <meta property="og:site_name" content="OpenAI" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="Jukebox" />
    <meta property="og:description" content="We’re introducing Jukebox, a neural net that generates music, including rudimentary singing, as raw audio in a variety of genres and artist styles. We’re releasing the model weights and code, along with a tool to explore the generated samples." />
    <meta property="og:url" content="https://openai.com/blog/jukebox/" />
    <meta property="og:image" content="https://openai.com/content/images/2020/04/2x-no-mark-1.jpg" />
    <meta property="article:published_time" content="2020-04-30T15:53:13.000Z" />
    <meta property="article:modified_time" content="2020-09-04T19:41:40.000Z" />
    <meta property="article:tag" content="Research" />
    <meta property="article:tag" content="Milestones" />
    
    <meta property="article:publisher" content="https://www.facebook.com/openai.research" />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="Jukebox" />
    <meta name="twitter:description" content="We’re introducing Jukebox, a neural net that generates music, including rudimentary singing, as raw audio in a variety of genres and artist styles. We’re releasing the model weights and code, along with a tool to explore the generated samples." />
    <meta name="twitter:url" content="https://openai.com/blog/jukebox/" />
    <meta name="twitter:image" content="https://openai.com/content/images/2020/04/2x-no-mark-1.jpg" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="OpenAI" />
    <meta name="twitter:label2" content="Filed under" />
    <meta name="twitter:data2" content="Research, Milestones" />
    <meta name="twitter:site" content="@openai" />
    <meta property="og:image:width" content="1276" />
    <meta property="og:image:height" content="1696" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "OpenAI",
        "url": "https://openai.com/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://openai.com/content/images/2019/05/openai-avatar.png",
            "width": 60,
            "height": 60
        }
    },
    "author": {
        "@type": "Person",
        "name": "OpenAI",
        "url": "https://openai.com/blog/authors/openai/",
        "sameAs": []
    },
    "headline": "Jukebox",
    "url": "https://openai.com/blog/jukebox/",
    "datePublished": "2020-04-30T15:53:13.000Z",
    "dateModified": "2020-09-04T19:41:40.000Z",
    "image": {
        "@type": "ImageObject",
        "url": "https://openai.com/content/images/2020/04/2x-no-mark-1.jpg",
        "width": 1276,
        "height": 1696
    },
    "keywords": "Research, Milestones",
    "description": "We’re introducing Jukebox, a neural net that generates music, including rudimentary singing, as raw audio in a variety of genres and artist styles. We’re releasing the model weights and code, along with a tool to explore the generated samples.",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://openai.com/"
    }
}
    </script>

    <meta name="generator" content="Ghost 4.1" />
    <link rel="alternate" type="application/rss+xml" title="OpenAI" href="" />
    <script defer src="https://unpkg.com/@tryghost/portal@~1.0.0/umd/portal.min.js" data-ghost="https://openai.com/"></script><style> .gh-post-upgrade-cta-content,
.gh-post-upgrade-cta {
    display: flex;
    flex-direction: column;
    align-items: center;
    font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen, Ubuntu, Cantarell, 'Open Sans', 'Helvetica Neue', sans-serif;
    text-align: center;
    width: 100%;
    color: #ffffff;
    font-size: 16px;
}

.gh-post-upgrade-cta-content {
    border-radius: 8px;
    padding: 40px 4vw;
}

.gh-post-upgrade-cta h2 {
    color: #ffffff;
    font-size: 28px;
    letter-spacing: -0.2px;
    margin: 0;
    padding: 0;
}

.gh-post-upgrade-cta p {
    margin: 20px 0 0;
    padding: 0;
}

.gh-post-upgrade-cta small {
    font-size: 16px;
    letter-spacing: -0.2px;
}

.gh-post-upgrade-cta a {
    color: #ffffff;
    cursor: pointer;
    font-weight: 500;
    box-shadow: none;
    text-decoration: underline;
}

.gh-post-upgrade-cta a:hover {
    color: #ffffff;
    opacity: 0.8;
    box-shadow: none;
    text-decoration: underline;
}

.gh-post-upgrade-cta a.gh-btn {
    display: block;
    background: #ffffff;
    text-decoration: none;
    margin: 28px 0 0;
    padding: 8px 18px;
    border-radius: 4px;
    font-size: 16px;
    font-weight: 600;
}

.gh-post-upgrade-cta a.gh-btn:hover {
    opacity: 0.92;
}</style>
    <style>
.post-header-btns {
  --fg: 255, 255, 255;
}

iframe[src^="https://w.soundcloud.com"] {
  margin-bottom: 0
}

/*#vqvae-image-1,
#vqvae-text-1 {
  transition: opacity 0.2s;
}
#vqvae-image-2,
#vqvae-text-2 {
  transition: visibility 0s 0.2s, opacity 0.2s;
}*/
#vqvae-image-2,
#vqvae-text-2 {
  visibility: hidden;
  opacity: 0;
}

.is-swapped #vqvae-image-1,
.is-swapped #vqvae-text-1 {
  opacity: 0;
}
.is-swapped #vqvae-image-2,
.is-swapped #vqvae-text-2 {
  visibility: visible;
  opacity: 1;
  /*transition: opacity 0.2s;*/
}
#audio-0,
#audio-1,
#audio-2,
#audio-3,
#audio-novel {
  cursor: pointer;
}

</style>
<style>:root {--ghost-accent-color: #15171A;}</style>
</head>
<body>
  
<article class="post" id="post-jukebox">
  
  <header
    class="post-header post-header--cover bg-light-warm-gray bg-cover color-white"
    style="background-image:url(https://cdn.openai.com/research-covers/jukebox/gradient.svg)"
    >
    <nav class="nav container" data-url="/blog/jukebox/">
  <div class="row py-0.75">
    <div class="col-6 col-sm">
      <a href="/" class="nav-wordmark d-block"><svg id="openai-wordmark" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 680 180"><path d="M410.22,41.09c-13.75,0-23.57,4.7-28.39,13.59l-2.59,4.79V43.41h-22.4v97.85H380.4V83.05c0-13.91,7.55-21.89,20.73-21.89,12.56,0,19.76,7.76,19.76,21.31v58.79h23.56v-63C444.45,55,431.65,41.09,410.22,41.09ZM296,41.09c-27.79,0-45.06,17.33-45.06,45.25v13.74c0,26.83,17.42,43.51,45.45,43.51,18.74,0,31.88-6.88,40.15-21l-14.61-8.39c-6.11,8.15-15.86,13.19-25.54,13.19-14.19,0-22.67-8.76-22.67-23.44v-3.89h65.79V83.82c0-26-17.08-42.73-43.51-42.73Zm22.08,43.14H273.72V81.89c0-16.12,7.91-25,22.28-25,13.83,0,22.08,8.76,22.08,23.44ZM678.32,27.3V8.58H596.87V27.3h28.56v95.25H596.87v18.71h81.45V122.55H649.76V27.3ZM60.67,5.87c-36.39,0-59,22.68-59,59.18V84.79c0,36.51,22.6,59.18,59,59.18s59-22.67,59-59.18V65.05C119.66,28.55,97.05,5.87,60.67,5.87ZM95.33,86.14c0,24.24-12.63,38.15-34.66,38.15S26,110.38,26,86.14V63.7c0-24.24,12.63-38.15,34.66-38.15S95.32,39.46,95.32,63.7Zm98.31-45c-12.36,0-23.07,5.11-28.64,13.69l-2.54,3.9V43.41H140.07V174.93h23.55V127.3l2.53,3.74c5.3,7.85,15.65,12.55,27.68,12.55,20.31,0,40.8-13.28,40.8-42.93V84c0-21.35-12.63-42.91-41-42.91Zm17.44,58.4c0,15.77-9.2,25.57-24,25.57-13.8,0-23.44-10.35-23.44-25.18V85.23c0-15.06,9.72-25.57,23.63-25.57,14.7,0,23.83,9.8,23.83,25.57ZM509.55,8.63,462,141.26h23.9l9.1-28.44h54.65l.09.28,9,28.16h23.93L535.08,8.58Zm-8.67,85.52L522.32,27l21.23,67.07Z"/></svg></a>
    </div>
    <div class="col-6 col-sm-7 col-md-6 col-lg-5 col-xl-4">
      <ul class="d-flex flex-column flex-sm-row justify-content-end justify-content-sm-between small-caps mt-n0.125 mt-sm-0">
                    
          <li class="mb-1/6 mb-sm-0"><a class="nav-link " href="/api/" data-slug="api">API</a></li>
          
          <li class="mb-1/6 mb-sm-0"><a class="nav-link " href="/projects/" data-slug="projects">Projects</a></li>
          
          <li class="mb-1/6 mb-sm-0"><a class="nav-link active-parent" href="/blog/" data-slug="blog">Blog</a></li>
          
          <li class="mb-sm-0"><a class="nav-link " href="/about/" data-slug="about">About</a></li>
      </ul>
    </div>
  </div>
</nav>


    <div class="container mt-3 pb-1">
      <div class="row">
        <div class="col-12">
          <div class="row">
            <div class="col-9 col-sm-8 col-md-5 col-xl-4 order-md-1 mb-0.5 mb-md-0">
              <figure class="release-cover mb-0 position-relative bg-fg-2 rounded-small overflow-hidden mb-1" style="padding-bottom:132.915360502%">
    <img
      class="position-absolute trbl-0 js-lazy"
      data-src="https://cdn.openai.com/research-covers/jukebox/2x-no-mark.jpg"
      alt="Jukebox">
</figure>
            </div>

            <div class="col-12 col-md">
              <div class="h-100 w-md-11/12 w-xl-10/12 max-width-xnarrow">
                <div class="h-100 d-flex flex-column justify-content-between" style="--fg:255,255,255">
                  <div>
                    <h1 class="balance-text h0  mb-0.75">Jukebox</h1>
                      <div class="post-excerpt color-fg mb-1 js-widow">
      We’re introducing Jukebox, a neural net that generates music, including rudimentary singing, as raw audio in a variety of genres and artist styles. We’re releasing the model weights and code, along with a tool to explore the generated samples.
  </div>
                    <div class="btns mt-1 mb-1 post-header-btns">
                      <a href="https://arxiv.org/abs/2005.00341" class="btn btn-padded icon-paper">Read Paper</a><a href="https://github.com/openai/jukebox/" class="btn btn-padded icon-code">View Code</a>
                    </div>
                  </div>
                  <div class="small-copy mt-0.25 mb-1 mb-md-10/12 color-fg">
                    <time datetime="2020-04-30">April 30, 2020</time>
                    <div class="reading-time">12 minute read, 10 day listen</div>
                  </div>
                </div>
              </div>
            </div>

          </div>
        </div>
      </div>
    </div>

  </header>

  <section class="container">
  <div class="row">
    <section class="content">
      
          
      
      <!--kg-card-begin: markdown--><div class="full mt-0 mb-1.5 mb-md-3" style="background-color:#fafafb">
<div class="container"><div class="row"><div class="content">
<!-- Header samples -->
<div class="mt-2.5 mb-2">
  <h2 id="curated">Curated samples</h2>
  <div class="medium-copy mb-1">Provided with genre, artist, and lyrics as input, Jukebox outputs a new music sample produced from scratch. Below, we show some of our favorite samples.</div>
  <div id="samples-css"></div>
  <div id="samples"></div>
  <div class="small-copy color-fg-60 mt-1.5 mb-0.5">To hear all uncurated samples, check out our sample&nbsp;explorer.</div>
  <a href="https://jukebox.openai.com/" class="btn btn-padded icon-external right mb-0">Explore All Samples</a>
</div>
<!-- when pasting in embeds, make sure `show_user` is `false` -->
</div></div></div>
</div><!-- end .full -->
<aside class="aside color-fg-60 small-copy">
  <div class="mt-0.25 mb-0.125">Contents</div>
  <ol class="list-indented list-compact">
    <li><a class="no-underline" href="#motivationandpriorwork">Motivation and prior work</a></li>
    <li><a class="no-underline" href="#approach">Approach</a></li>
    <li><a class="no-underline" href="#limitations">Limitations</a></li>
    <li><a class="no-underline" href="#futuredirections">Future directions</a></li>
    <li><a class="no-underline" href="#timeline">Timeline</a></li>
  </ol>
</aside>
<hr class="d-md-none">
<h2 id="motivationandpriorwork">Motivation and prior work</h2>
<p>Automatic music generation dates back to more than half a century.<span class="js-rfref" data-id="hiller"></span><span class="js-rfref" data-id="moorer"></span><span class="js-rfref" data-id="beyls"></span><span class="js-rfref" data-id="conklin"></span> A prominent approach is to generate music symbolically in the form of a piano roll, which specifies the timing, pitch, velocity, and instrument of each note to be played. This has led to impressive results like producing Bach chorals,<span class="js-rfref" data-id="hadjeres"></span><span class="js-rfref" data-id="huang-2019"></span> polyphonic music with multiple instruments,<span class="js-rfref" data-id="dong"></span><span class="js-rfref" data-id="yang"></span><span class="js-rfref" data-id="roberts"></span> as well as minute long musical pieces.<span class="js-rfref" data-id="huang-2018"></span><span class="js-rfref" data-id="payne"></span><span class="js-rfref" data-id="wu"></span></p>
<p>But symbolic generators have limitations—they cannot capture human voices or many of the more subtle timbres, dynamics, and expressivity that are essential to music. A different approach<sup class="footnote-ref"><a href="#fn1" id="fnref1">[1]</a></sup> is to model music directly as raw audio.<span class="js-rfref" data-id="oord-2016"></span><span class="js-rfref" data-id="mehri"></span><span class="js-rfref" data-id="yamamoto"></span><span class="js-rfref" data-id="vasquez"></span> Generating music at the audio level is challenging since the sequences are very long.<span class="js-rfref" data-id="dieleman"></span> A typical 4-minute song at CD quality (44 kHz, 16-bit) has over 10 million timesteps. For comparison, GPT-2 had 1,000 timesteps and <a href="https://openai.com/projects/five/">OpenAI Five</a> took tens of thousands of timesteps per game. Thus, to learn the high level semantics of music, a model would have to deal with extremely long-range dependencies.</p>
<p>One way of addressing the long input problem is to use an autoencoder that compresses raw audio to a lower-dimensional space by discarding some of the perceptually irrelevant bits of information. We can then train a model to generate audio in this compressed space, and upsample back to the raw audio space.<span class="js-rfref" data-id="van-den-oord"></span><span class="js-rfref" data-id="dieleman"></span></p>
<p>We chose to work on music because we want to continue to push the boundaries of generative models. Our previous work on <a href="https://openai.com/blog/musenet">MuseNet</a> explored synthesizing music based on large amounts of MIDI data. Now in raw audio, our models must learn to tackle high diversity as well as very long range structure, and the raw audio domain is particularly unforgiving of errors in short, medium, or long term timing.</p>
<figure id="overview" class="mt-2 mb-2.5">
<!-- 1 -->
<div class="mb-1/3">
  <div class="position-relative" style="padding-bottom:5.555556%">
    <div id="overview-1" class="position-absolute trbl-0"><img src="https://cdn.openai.com/jukebox/assets/waveforms/1-original.png"></div>
  </div>
</div>
<div class="small-copy color-fg-60"><strong class="color-fg">Raw audio</strong>&ensp;44.1k samples per second, where each sample is a float that represents the amplitude of sound at that moment in&nbsp;time</div>
<div class="row narrow-gutters align-items-center mb-0.25">
  <div class="col-auto col-sm-6">
    <img src="https://cdn.openai.com/jukebox/assets/overview-arrow.svg" class="ml-auto mb-0" style="width:5px">
  </div>
  <div class="col col-sm-6">
    <div class="small-copy balance-text">
      Encode using CNNs (convolutional neural networks)
    </div>
  </div>
</div>
<!-- 2 -->
<div class="mb-1/3">
  <div class="bg-light-warm-gray position-relative" style="padding-bottom:5.555556%">
    <div id="overview-2" class="position-absolute trbl-0"><img src="https://cdn.openai.com/jukebox/assets/overview-2.svg"></div>
  </div>
</div>
<div class="small-copy color-fg-60"><strong class="color-fg">Compressed audio</strong>&ensp;344 samples per second, where each sample is 1 of 2048 possible vocab&nbsp;tokens</div>
<div class="row narrow-gutters align-items-center mb-0.25">
  <div class="col-auto col-sm-6">
    <img src="https://cdn.openai.com/jukebox/assets/overview-arrow.svg" class="ml-auto mb-0" style="width:5px">
  </div>
  <div class="col col-sm-6">
    <div class="small-copy balance-text">
      Generate novel patterns from trained transformer conditioned on lyrics
    </div>
  </div>
</div>
<!-- 3 -->
<div class="mb-1/3">
  <div class="position-relative" style="padding-bottom:5.555556%">
    <div id="overview-3" class="position-absolute trbl-0"><img src="https://cdn.openai.com/jukebox/assets/overview-3.svg"></div>
  </div>
</div>
<div class="small-copy color-fg-60"><strong class="color-fg">Novel compressed audio</strong>&ensp;344 samples per second</div>
<div class="row narrow-gutters align-items-center mb-0.25">
  <div class="col-auto col-sm-6">
    <img src="https://cdn.openai.com/jukebox/assets/overview-arrow.svg" class="ml-auto mb-0" style="width:5px">
  </div>
  <div class="col col-sm-6">
    <div class="small-copy balance-text">
      Upsample using transformers and decode using CNNs
    </div>
  </div>
</div>
<!-- 4 -->
<div class="mb-1/3">
  <div class="position-relative" style="padding-bottom:5.555556%">
    <div id="overview-4" class="position-absolute trbl-0"><img src="https://cdn.openai.com/jukebox/assets/waveforms/1-novel.png"></div>
  </div>
</div>
<div class="small-copy color-fg-60"><strong class="color-fg">Novel raw audio</strong>&ensp;44.1k samples per second</div>
</figure>
<!-- end #overview -->
<h2 id="approach">Approach</h2>
<h3 id="compressingmusictodiscretecodes">Compressing music to discrete codes</h3>
<p>Jukebox's autoencoder model compresses audio to a discrete space, using a quantization-based approach called VQ-VAE.<span class="js-rfref" data-id="van-den-oord"></span> Hierarchical VQ-VAEs<span class="js-rfref" data-id="dieleman"></span> can generate short instrumental pieces from a few sets of instruments, however they suffer from hierarchy collapse due to use of successive encoders coupled with autoregressive decoders. A simplified variant called VQ-VAE-2<span class="js-rfref" data-id="razavi"></span> avoids these issues by using feedforward encoders and decoders only, and they show impressive results at generating high-fidelity images.</p>
<p>We draw inspiration from VQ-VAE-2 and apply their approach to music. We modify their architecture as follows:</p>
<ul>
<li>To alleviate codebook collapse common to VQ-VAE models, we use random restarts where we randomly reset a codebook vector to one of the encoded hidden states whenever its usage falls below a threshold.</li>
<li>To maximize the use of the upper levels, we use separate decoders and independently reconstruct the input from the codes of each level.</li>
<li>To allow the model to reconstruct higher frequencies easily, we add a spectral loss<span class="js-rfref" data-id="oord-2017"></span><span class="js-rfref" data-id="arik"></span> that penalizes the norm of the difference of input and reconstructed spectrograms.</li>
</ul>
<p>We use three levels in our VQ-VAE, shown below, which compress the 44kHz raw audio by 8x, 32x, and 128x, respectively, with a codebook size of 2048 for each level. This downsampling loses much of the audio detail, and sounds noticeably noisy as we go further down the levels. However, it retains essential information about the pitch, timbre, and volume of the audio.</p>
<!-- start vqvae -->
<div id="vqvae" class="full my-2 py-2 bg-fg-2">
<div class="container"><div class="row"><div class="content">
<!-- switch -->
<div class="clearfix mb-2/3">
<div class="switch">
  <input type="radio" class="switch-input" name="switch-vqvae" value="compress" id="compress-switch" onclick="toggle('vqvae', 'is-swapped', false)" checked>
  <label for="compress-switch" class="switch-label switch-label-off small-caps">1. Compress</label>
  <input type="radio" class="switch-input" name="switch-vqvae" value="generate" id="generate-switch" onclick="toggle('vqvae', 'is-swapped', true)">
  <label for="generate-switch" class="switch-label switch-label-on small-caps">2. Generate</label>
  <span class="switch-selection"></span>
</div>
</div>
<!-- text -->
<div class="medium-small-copy position-relative mb-1 mb-md-0.25">
<div id="vqvae-text-1">
Each VQ-VAE level independently encodes the input. The bottom level encoding produces the highest quality reconstruction, while the top level encoding retains only the essential musical information.
</div>
<div id="vqvae-text-2" class="position-absolute trbl-0">
To generate novel songs, a cascade of transformers generates codes from top to bottom level, after which the bottom-level decoder can convert them to raw audio.
</div>
</div>
<!-- image -->
<div class="wide my-0 overflow-hidden">
<div class="position-relative w-100">
<div id="vqvae-image-1" class="mx-auto" style="max-width:1050px">
  <div class="position-relative">
    <img src="https://cdn.openai.com/jukebox/assets/vqvae-1.svg" class="mb-0">
    <div class="position-absolute trbl-0">
      <svg width="1050" height="616" viewBox="0 0 1050 616" fill="none" xmlns="http://www.w3.org/2000/svg" style="max-width:100%;height:auto">
      <g id="vqvae-1-play">
      <rect id="audio-0" y="515" width="240" height="82" fill="transparent"/>
      <rect id="audio-1" x="270" y="515" width="240" height="82" fill="transparent"/>
      <rect id="audio-2" x="540" y="515" width="240" height="82" fill="transparent"/>
      <rect id="audio-3" x="810" y="515" width="240" height="82" fill="transparent"/>
      </g>
      </svg>
    </div>
  </div>
</div>
<div id="vqvae-image-2" class="mx-auto position-absolute trbl-0" style="max-width:1050px">
  <div class="position-relative">
    <img src="https://cdn.openai.com/jukebox/assets/vqvae-2.svg" class="mb-0">
    <div class="position-absolute trbl-0">
      <svg width="1050" height="616" viewBox="0 0 1050 616" fill="none" xmlns="http://www.w3.org/2000/svg">
      <g id="vqvae-2-play">
      <rect id="audio-novel" x="270" y="515" width="240" height="82" fill="transparent"/>
      </g>
      </svg>
    </div>
  </div>
</div>
</div>
</div>
</div></div><!-- end .row .content -->
</div><!-- end .container -->
</div><!-- end #vqvae -->
<h3 id="generatingcodesusingtransformers">Generating codes using transformers</h3>
<p>Next, we train the prior models whose goal is to learn the distribution of music codes encoded by VQ-VAE and to generate music in this compressed discrete space. Like the VQ-VAE, we have three levels of priors: a top-level prior that generates the most compressed codes, and two upsampling priors that generate less compressed codes conditioned on above.</p>
<p>The top-level prior models the long-range structure of music, and samples decoded from this level have lower audio quality but capture high-level semantics like singing and melodies. The middle and bottom upsampling priors add local musical structures like timbre, significantly improving the audio quality.</p>
<p>We train these as autoregressive models using a simplified variant of Sparse Transformers.<span class="js-rfref" data-id="child"></span><span class="js-rfref" data-id="vaswani"></span> Each of these models has 72 layers of factorized self-attention on a context of 8192 codes, which corresponds to approximately 24 seconds, 6 seconds, and 1.5 seconds of raw audio at the top, middle and bottom levels, respectively.</p>
<p>Once all of the priors are trained, we can generate codes from the top level, upsample them using the upsamplers, and decode them back to the raw audio space using the VQ-VAE decoder to sample novel songs.</p>
<h3 id="dataset">Dataset</h3>
<p>To train this model, we crawled the web to curate a new dataset of 1.2 million songs (600,000 of which are in English), paired with the corresponding lyrics and metadata from <a href="https://lyrics.fandom.com/wiki/LyricWiki">LyricWiki</a>. The metadata includes artist, album genre, and year of the songs, along with common moods or playlist keywords associated with each song. We train on 32-bit, 44.1 kHz raw audio, and perform data augmentation by randomly downmixing the right and left channels to produce mono audio.</p>
<h3 id="artistandgenreconditioning">Artist and genre conditioning</h3>
<p>The top-level transformer is trained on the task of predicting compressed audio tokens. We can provide additional information, such as the artist and genre for each song. This has two advantages: first, it reduces the entropy of the audio prediction, so the model is able to achieve better quality in any particular style; second, at generation time, we are able to steer the model to generate in a style of our choosing.</p>
<p>This t-SNE<span class="js-rfref" data-id="maaten"></span> below shows how the model learns, in an unsupervised way, to cluster similar artists and genres close together, and also makes some surprising associations like Jennifer Lopez being so close to Dolly Parton!</p>
<!-- t-SNE -->
<div id="tsne-styles"></div>
<div class="full pt-0.5 my-2 mb-md-2.5" style="background-color:#fafafb">
<div class="container">
  <div class="mx-auto" style="max-width:1200px">
    <div id="tsne" class="aspect-1/1"></div>
  </div>
</div>
</div>
<h3 id="lyricsconditioning">Lyrics conditioning</h3>
<p>In addition to conditioning on artist and genre, we can provide more context at training time by conditioning the model on the lyrics for a song. A significant challenge is the lack of a well-aligned dataset: we only have lyrics at a song level without alignment to the music, and thus for a given chunk of audio we don’t know precisely which portion of the lyrics (if any) appear. We also may have song versions that don’t match the lyric versions, as might occur if a given song is performed by several different artists in slightly different ways.  Additionally, singers frequently repeat phrases, or otherwise vary the lyrics, in ways that are not always captured in the written lyrics.</p>
<p>To match audio portions to their corresponding lyrics, we begin with a simple heuristic that aligns the characters of the lyrics to linearly span the duration of each song, and pass a fixed-size window of characters centered around the current segment during training. While this simple strategy of linear alignment worked surprisingly well, we found that it fails for certain genres with fast lyrics, such as hip hop. To address this, we use Spleeter<span class="js-rfref" data-id="hennequin"></span> to extract vocals from each song and run NUS AutoLyricsAlign<span class="js-rfref" data-id="gupta"></span> on the extracted vocals to obtain precise word-level alignments of the lyrics. We chose a large enough window so that the actual lyrics have a high probability of being inside the window.</p>
<p>To attend to the lyrics, we add an encoder to produce a representation for the lyrics, and add attention layers that use queries from the music decoder to attend to keys and values from the lyrics encoder. After training, the model learns a more precise alignment.</p>
<!-- start lyrics visual -->
<div class="mt-1.5 mb-2">
<p><img src="https://cdn.openai.com/jukebox/assets/lyrics-attention.svg" alt="lyrics-attention" loading="lazy"></p>
<div class="caption"><strong class="color-fg">Lyric–music alignment learned by encoder–decoder attention layer</strong><br>Attention progresses from one lyric token to the next as the music progresses, with a few moments of uncertainty.</div>
</div>
<!-- end lyrics visual -->
<h2 id="limitations">Limitations</h2>
<p>While Jukebox represents a step forward in musical quality, coherence, length of audio sample, and ability to condition on artist, genre, and lyrics, there is a significant gap between these generations and human-created music.</p>
<p>For example, while the generated songs show local musical coherence, follow traditional chord patterns, and can even feature impressive solos, we do not hear familiar larger musical structures such as choruses that repeat. Our downsampling and upsampling process introduces discernable noise. Improving the VQ-VAE so its codes capture more musical information would help reduce this. Our models are also slow to sample from, because of the autoregressive nature of sampling. It takes approximately 9 hours to fully render one minute of audio through our models, and thus they cannot yet be used in interactive applications. Using techniques<span class="js-rfref" data-id="oord-2017"></span><span class="js-rfref" data-id="kingma"></span> that distill the model into a parallel sampler can significantly speed up the sampling speed. Finally, we currently train on English lyrics and mostly Western music, but in the future we hope to include songs from other languages and parts of the world.</p>
<h2 id="futuredirections">Future directions</h2>
<p>Our audio team is continuing to work on generating audio samples conditioned on different kinds of priming information.  In particular, we've seen early success conditioning on MIDI files and stem files. Here's an example of a <a href="https://soundcloud.com/openai_audio/generated-raw">raw audio sample</a> conditioned on <a href="https://soundcloud.com/openai_audio/midi-input-given-to-model-as-midi-tokens-rendered-here-by-timidity">MIDI tokens</a>.  We hope this will improve the musicality of samples (in the way conditioning on lyrics improved the singing), and this would also be a way of giving musicians more control over the generations. We expect human and model collaborations to be an increasingly exciting creative space. If you’re excited to work on these problems with us, <a href="https://openai.com/jobs/">we’re hiring</a>.</p>
<p>As generative modeling across various domains continues to advance, we are also conducting research into issues like <a href="https://arxiv.org/abs/1908.09203">bias</a> and <a href="https://cdn.openai.com/policy-submissions/OpenAI+Comments+on+Intellectual+Property+Protection+for+Artificial+Intelligence+Innovation.pdf">intellectual property rights</a>, and are engaging with people who work in the domains where we develop tools. To better understand future implications for the music community, we shared Jukebox with an initial set of 10 musicians from various genres to discuss their feedback on this work. While Jukebox is an interesting research result, these musicians did not find it immediately applicable to their creative process given some of its current <a href="#limitations">limitations</a>. We are connecting with the wider creative community as we think generative work across text, images, and audio will continue to improve. If you're interested in being a creative collaborator to help us build <a href="https://openai.com/blog/musenet/">useful tools</a> or new works of art in these domains, please <a href="https://forms.gle/8npHSMnE5hfSxkkU9">let us know</a>!</p>
<section class="btns"><a href="https://forms.gle/8npHSMnE5hfSxkkU9" class="btn btn-padded icon-external right">Creative Collaborator Sign-Up</a></section>
<p><em>To connect with the corresponding authors, please email <a href="mailto:jukebox@openai.com">jukebox@openai.com</a>.</em></p>
<!-- start timeline -->
<div class="full bg-shadow">
<div class="container">
<div class="row">
<div class="content">
<ul class="timeline" id="timeline">
<h4>Timeline</h4>
<li data-date="August 2019">
Our first raw audio model, which learns to recreate instruments like Piano and Violin. We try a dataset of rock and pop songs, and surprisingly it works.
<!-- Early August: Piano -->
<hr class="my-5/12 mt-1">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762987670%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<!-- Late August: Hints of Pop -->
<hr class="my-5/12">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762983845%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<hr class="my-5/12">
</li>
<br>
<li data-date="October 2019">
We collect a larger and more diverse dataset of songs, with labels for genres and artists. Model picks up artist and genre styles more consistently with diversity, and at convergence can also produce full-length songs with long-range coherence.
<!-- Late October: In the style of Bob Marley -->
<hr class="my-5/12 mt-1">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762992857%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<!-- Late October: In the style of Rock and Roll -->
<hr class="my-5/12">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762992881%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<!-- Late October: In the style of Louis Armstrong -->
<hr class="my-5/12">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762993565%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<hr class="my-5/12">
<!-- Late October: In the style of Blues -->
<!-- <hr class="my-5/12">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762992890%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe> -->
</li>
<br>
<li data-date="January 2020">
We scale our VQ-VAE from 22 to 44kHz to achieve higher quality audio. We also scale top-level prior from 1B to 5B to capture the increased information. We see better musical quality, clear singing, and long-range coherence. We also make novel completions of real songs.
<!-- Early January: In the style of Hip Hop/Rap -->
<hr class="my-5/12 mt-1">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762974362%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<!-- Early January: In the style of David Bowie -->
<hr class="my-5/12">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762970192%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<!-- Late January: In the style of Frank Sinatra -->
<hr class="my-5/12">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762972598%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<!-- Early January: Early January: Generation following 12 seconds of priming -->
<hr class="my-5/12">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/762975382%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<hr class="my-5/12">
</li>
<br>
<li data-date="February 2020">
We start training models conditioned on lyrics to incorporate further conditioning information. We only have unaligned lyrics, so model has to learn alignment and pronunciation, as well as singing.
<!-- February: In the style of Kylie Minogue ("Count Every Minute") -->
<hr class="my-5/12 mt-1">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/758998687%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<!-- February: In the style of Frank Sinatra ("See Your Face Again") -->
<hr class="my-5/12">
<iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" class="js-lazy" data-src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/758998978%3F&color=%23ff5500&inverse=false&auto_play=false&show_user=false"></iframe>
<hr class="my-5/12">
</li>
</ul>
</div><!-- end .content -->
</div><!-- end .row -->
</div><!-- end .container -->
</div><!-- end .full -->
<!-- end timeline -->
<footer class="post-footer js-post-footer">
<!-- footer item -->
<div><hr><div class="row">
<div class="col">Acknowledgments</div>
<div class="col">
Thank you to the following for their feedback on this work and contributions to this release:
Jack Clark, Gretchen Krueger, Miles Brundage, Jeff Clune, Jakub Pachocki, Ryan Lowe, Shan Carter, David Luan, Vedant Misra, Daniela Amodei, Greg Brockman, Kelly Sims, Karson Elmgren, Bianca Martin, Rewon Child, Will Guss, Rob Laidlow, Rachel White, Delwin Campbell, Tasso Smith, Matthew Suttor, Konrad Kaczmarek, Scott Petersen, Dakota Stipp, Jena Ezzeddine
</div>
</div></div>
<!-- footer item -->
<div><hr><div class="row">
<div class="col">Editor</div>
<div class="col">Ashley Pilipiszyn</div>
</div></div>
<!-- footer item -->
<div><hr><div class="row">
<div class="col">Design & Development </div>
<div class="col">Justin Jay Wang & Brooke Chan</div>
</div></div>
<!-- footer item -->
<div><hr><div class="row">
<div class="col">Cover Art</div>
<div class="col">Ben Barry</div>
</div></div>
<!-- footer item -->
<div data-order="-1"><hr><div class="row" id="references">
<div class="col">References</div>
<div class="col">
<ol>
<li class="js-ref" data-id="hiller">
Hiller Jr, L. A., and L. M. Isaacson. "<a href="http://www.aes.org/e-lib/browse.cfm?elib=231">Musical Composition with a High-Speed Digital Computer</a>." Journal of the Audio Engineering Society 6.3 (1958): 154-160.
</li>
<li class="js-ref" data-id="moorer">
Moorer, James Anderson. "<a href="https://dl.acm.org/doi/10.1145/361254.361265">Music and computer composition</a>." Communications of the ACM 15.2 (1972): 104-113.
</li>
<li class="js-ref" data-id="beyls">
Beyls, Peter. "<a href="https://quod.lib.umich.edu/i/icmc/bbp2372.1989.009/--musical-universe-of-cellular-automata">The musical universe of cellular automata</a>." Proceedings of international computer music conference. 1989.
</li>
<li class="js-ref" data-id="conklin">
Conklin, Darrell. "<a href="http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.3.2086&rep=rep1&type=pdf">Music generation from statistical models</a>." Proceedings of the AISB 2003 Symposium on Artificial Intelligence and Creativity in the Arts and Sciences. 2003.
</li>
<li class="js-ref" data-id="hadjeres">
Hadjeres, Gaëtan, François Pachet, and Frank Nielsen. "<a href="https://dl.acm.org/doi/10.5555/3305381.3305522">Deepbach: a steerable model for bach chorales generation</a>." Proceedings of the 34th International Conference on Machine Learning-Volume 70. JMLR. org, 2017.
</li>
<li class="js-ref" data-id="huang-2019">
Huang, Cheng-Zhi Anna, et al. "<a href="https://arxiv.org/abs/1903.07227">Counterpoint by convolution</a>." arXiv preprint arXiv:1903.07227 (2019).
</li>
<li class="js-ref" data-id="dong">
Dong, Hao-Wen, et al. "<a href="https://www.aaai.org/ocs/index.php/AAAI/AAAI18/paper/viewPaper/17286">Musegan: Multi-track sequential generative adversarial networks for symbolic music generation and accompaniment</a>." Thirty-Second AAAI Conference on Artificial Intelligence. 2018.
</li>
<li class="js-ref" data-id="yang">
Yang, Li-Chia, Szu-Yu Chou, and Yi-Hsuan Yang. "<a href="https://arxiv.org/abs/1703.10847">MidiNet: A convolutional generative adversarial network for symbolic-domain music generation</a>." arXiv preprint arXiv:1703.10847 (2017).
</li>
<li class="js-ref" data-id="roberts">
Roberts, Adam, et al. "<a href="https://arxiv.org/abs/1803.05428">A hierarchical latent vector model for learning long-term structure in music</a>." arXiv preprint arXiv:1803.05428 (2018).
</li>
<li class="js-ref" data-id="huang-2018">
Huang, Cheng-Zhi Anna, et al. "<a href="https://arxiv.org/abs/1809.04281">Music transformer</a>." arXiv preprint arXiv:1809.04281 (2018).
</li>
<li class="js-ref" data-id="payne">
Payne, Christine. "<a href="https://openai.com/blog/musenet">MuseNet, 2019.</a>" URL <samp>openai.com/blog/musenet</samp> (2019).
</li>
<li class="js-ref" data-id="wu">
Wu, Jian, et al. "<a href="https://ieeexplore.ieee.org/abstract/document/8918424">A hierarchical recurrent neural network for symbolic melody generation</a>." IEEE Transactions on Cybernetics (2019).
</li>
<li class="js-ref" data-id="oord-2016">
Oord, Aaron van den, et al. "<a href="https://arxiv.org/abs/1609.03499">Wavenet: A generative model for raw audio</a>." arXiv preprint arXiv:1609.03499 (2016).
</li>
<li class="js-ref" data-id="mehri">
Mehri, Soroush, et al. "<a href="https://arxiv.org/abs/1612.07837">SampleRNN: An unconditional end-to-end neural audio generation model</a>." arXiv preprint arXiv:1612.07837 (2016).
</li>
<li class="js-ref" data-id="yamamoto">
Yamamoto, Ryuichi, Eunwoo Song, and Jae-Min Kim. "<a href="https://ieeexplore.ieee.org/abstract/document/9053795/">Parallel WaveGAN: A fast waveform generation model based on generative adversarial networks with multi-resolution spectrogram</a>." ICASSP 2020-2020 IEEE International Conference on Acoustics, Speech and Signal Processing (ICASSP). IEEE, 2020.
</li>
<li class="js-ref" data-id="vasquez">
Vasquez, Sean, and Mike Lewis. "<a href="https://arxiv.org/abs/1906.01083">Melnet: A generative model for audio in the frequency domain</a>." arXiv preprint arXiv:1906.01083 (2019).
</li>
<li class="js-ref" data-id="dieleman">
Dieleman, Sander, Aaron van den Oord, and Karen Simonyan. "<a href="http://papers.nips.cc/paper/8023-the-challenge-of-realistic-music-generation-modelling-raw-audio-at-scale">The challenge of realistic music generation: modelling raw audio at scale</a>." Advances in Neural Information Processing Systems. 2018.
</li>
<li class="js-ref" data-id="kim">
Kim, Jong Wook, et al. "<a href="https://neural-music-synthesis.github.io/">Neural music synthesis for flexible timbre control</a>." ICASSP 2019-2019 IEEE International Conference on Acoustics, Speech and Signal Processing (ICASSP). IEEE, 2019.
</li>
<li class="js-ref" data-id="hawthorne">
Hawthorne, Curtis, et al. "<a href="https://arxiv.org/abs/1810.12247">Enabling factorized piano music modeling and generation with the MAESTRO dataset</a>." arXiv preprint arXiv:1810.12247 (2018).
</li>
<li class="js-ref" data-id="engel-2017">
Engel, Jesse, et al. "<a href="https://magenta.tensorflow.org/nsynth">Neural audio synthesis of musical notes with wavenet autoencoders</a>." Proceedings of the 34th International Conference on Machine Learning-Volume 70. JMLR. org, 2017.
</li>
<li class="js-ref" data-id="engel-2019">
Engel, Jesse, et al. "<a href="https://magenta.tensorflow.org/gansynth">Gansynth: Adversarial neural audio synthesis</a>." arXiv preprint arXiv:1902.08710 (2019).
</li>
<li class="js-ref" data-id="brunner">
Brunner, Gino, et al. "<a href="https://arxiv.org/abs/1809.07600">MIDI-VAE: Modeling dynamics and instrumentation of music with applications to style transfer</a>." arXiv preprint arXiv:1809.07600 (2018).
</li>
<li class="js-ref" data-id="donahue">
Donahue, Chris, et al. "<a href="https://arxiv.org/abs/1907.04868">LakhNES: Improving multi-instrumental music generation with cross-domain pre-training</a>." arXiv preprint arXiv:1907.04868 (2019).
</li>
<li class="js-ref" data-id="mor">
Mor, Noam, et al. "<a href="https://arxiv.org/abs/1805.07848">A universal music translation network</a>." arXiv preprint arXiv:1805.07848 (2018).
</li>
<li class="js-ref" data-id="van-den-oord">
van den Oord, Aaron, and Oriol Vinyals. "<a href="http://papers.nips.cc/paper/7210-neural-discrete-representation-learning">Neural discrete representation learning</a>." Advances in Neural Information Processing Systems. 2017.
</li>
<li class="js-ref" data-id="razavi">
Razavi, Ali, Aaron van den Oord, and Oriol Vinyals. "<a href="http://papers.nips.cc/paper/9625-generating-diverse-high-fidelity-images-with-vq-vae-2">Generating diverse high-fidelity images with VQ-VAE-2</a>." Advances in Neural Information Processing Systems. 2019.
</li>
<li class="js-ref" data-id="oord-2017">
Oord, Aaron van den, et al. "<a href="https://arxiv.org/abs/1711.10433">Parallel wavenet: Fast high-fidelity speech synthesis</a>." arXiv preprint arXiv:1711.10433 (2017).
</li>
<li class="js-ref" data-id="arik">
Arık, Sercan Ö., Heewoo Jun, and Gregory Diamos. "<a href="https://arxiv.org/abs/1808.06719">Fast spectrogram inversion using multi-head convolutional neural networks</a>." IEEE Signal Processing Letters 26.1 (2018): 94-98.
</li>
<li class="js-ref" data-id="child">
Child, Rewon, et al. "<a href="https://arxiv.org/abs/1904.10509">Generating long sequences with sparse transformers</a>." arXiv preprint arXiv:1904.10509 (2019).
</li>
<li class="js-ref" data-id="vaswani">
Vaswani, Ashish, et al. "<a href="https://arxiv.org/abs/1706.03762">Attention is all you need</a>." Advances in neural information processing systems. 2017.
</li>
<li class="js-ref" data-id="maaten">
Maaten, Laurens van der, and Geoffrey Hinton. "<a href="https://lvdmaaten.github.io/tsne/">Visualizing data using t-SNE</a>." Journal of machine learning research 9.Nov (2008): 2579-2605.
</li>
<li class="js-ref" data-id="hennequin">
Hennequin, Romain, et al. "<a href="https://github.com/deezer/spleeter">Spleeter: A fast and state-of-the art music source separation tool with pre-trained models</a>." Proc. International Society for Music Information Retrieval Conference. 2019.
</li>
<li class="js-ref" data-id="gupta">
Gupta, Chitralekha, Emre Yılmaz, and Haizhou Li. "<a href="https://autolyrixalign.hltnus.org/">Lyrics-to-Audio Alignment with Music-aware Acoustic Models</a>."
</li>
<li class="js-ref" data-id="kingma">
Kingma, Durk P., et al. "<a href="http://papers.nips.cc/paper/6581-improved-variational-inference-with-inverse-autoregressive-flow">Improved variational inference with inverse autoregressive flow</a>." Advances in neural information processing systems. 2016.
</li>
</div>
</div></div>
<!-- special footer item for footnotes -->
<div data-order="-2"><hr><div class="row" id="footnotes">
<div class="col">Footnotes</div>
<div class="col">
<hr class="footnotes-sep">
<section class="footnotes">
<ol class="footnotes-list">
<li id="fn1" class="footnote-item"><p>One can also use a hybrid approach—first generate the symbolic music, then render it to raw audio using a wavenet conditioned on piano rolls,<span class="js-rfref" data-id="kim"></span><span class="js-rfref" data-id="hawthorne"></span> an autoencoder,<span class="js-rfref" data-id="engel-2017"></span> or a GAN<span class="js-rfref" data-id="engel-2019"></span>—or do music style transfer, to transfer styles between classical and jazz music,<span class="js-rfref" data-id="brunner"></span> generate chiptune music,<span class="js-rfref" data-id="donahue"></span> or disentangle musical style and content.<span class="js-rfref" data-id="mor"></span> For a deeper dive into raw audio modelling, we recommend this excellent <a href="https://benanne.github.io/2020/03/24/audio-generation.html">overview</a>. <a href="#fnref1" class="footnote-backref">↩︎</a></p>
</li>
</ol>
</section>
<!--kg-card-end: markdown-->
    </section>
  </div>
</section>
  <footer class="post-footer post-footer--authors container js-post-footer-authors">
  <div data-order="0">
    <hr>
    <div class="row" id="authors">
      <div class="col">Authors</div>
      <div class="col js-post-footer-authors-list ">
        <span class="post-author"><a class="fade" href="/blog/authors/prafulla/">Prafulla Dhariwal</a></span><span class="post-author"><a class="fade" href="/blog/authors/heewoo/">Heewoo Jun</a></span><span class="post-author"><a class="fade" href="/blog/authors/christine/">Christine McLeavey Payne</a></span><span class="post-author"><a class="fade" href="/blog/authors/jong/">Jong Wook Kim</a></span><span class="post-author"><a class="fade" href="/blog/authors/alec/">Alec Radford</a></span><span class="post-author"><a class="fade" href="/blog/authors/ilya/">Ilya Sutskever</a></span>
      </div>
    </div>
  </div>
</footer>


<footer class="post-footer post-footer--tags container js-post-footer-tags">
  <div>
    <hr>
    <div class="row" id="tags">
      <div class="col">Filed Under</div>
      <div class="col js-post-footer-tags-list">
        <span class="post-tag"><a class="fade" href="/blog/tags/research/">Research</a></span><span class="post-tag"><a class="fade" href="/blog/tags/milestones/">Milestones</a></span>
      </div>
    </div>
  </div>
</footer>


</article>
  

  <footer class="footer container">
  <div class="row line-height-1.65 mb-1.5 medium-xsmall-copy">
    <div class="col-12 col-md-3 col-xl-3">
      <a href="/" class="d-block footer-logo mb-1 position-relative" style="left:-1px"><svg id="openai-horizontal" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 936 232"><path d="M667.21,90.58c-13.76,0-23.58,4.7-28.4,13.6L636.22,109V92.9H613.83v97.86h23.55V132.54c0-13.91,7.56-21.89,20.73-21.89,12.56,0,19.76,7.77,19.76,21.31v58.8h23.56v-63C701.43,104.46,688.64,90.58,667.21,90.58ZM553,90.58c-27.79,0-45,17.34-45,45.25v13.74c0,26.84,17.41,43.51,45.44,43.51,18.75,0,31.89-6.87,40.16-21L579,163.68c-6.11,8.15-15.87,13.2-25.55,13.2-14.19,0-22.66-8.76-22.66-23.44v-3.89h65.73V133.32c0-26-17.07-42.74-43.5-42.74Zm22.09,43.15H530.71v-2.35c0-16.11,7.91-25,22.27-25,13.83,0,22.09,8.76,22.09,23.44ZM935.31,76.79V58.07H853.85V76.79h28.56V172H853.85v18.72h81.46V172H906.74V76.79ZM317.65,55.37c-36.38,0-59,22.67-59,59.18v19.74c0,36.5,22.61,59.18,59,59.18s59-22.68,59-59.18V114.55C376.64,78,354,55.37,317.65,55.37Zm34.66,80.27c0,24.24-12.63,38.14-34.66,38.14S283,159.88,283,135.64V113.19c0-24.24,12.64-38.14,34.66-38.14s34.66,13.9,34.66,38.14Zm98.31-45.06c-12.36,0-23.06,5.12-28.64,13.69l-2.53,3.9V92.9h-22.4V224.43h23.56V176.79l2.52,3.74c5.3,7.86,15.65,12.55,27.69,12.55,20.31,0,40.8-13.27,40.8-42.93V133.51c0-21.37-12.63-42.93-41-42.93ZM468.06,149c0,15.77-9.2,25.57-24,25.57-13.8,0-23.43-10.36-23.43-25.18V134.67c0-15,9.71-25.56,23.63-25.56,14.69,0,23.82,9.79,23.82,25.56ZM766.53,58.08,719,190.76h23.93l9.1-28.44h54.64l.09.28,9,28.16h23.92L792.07,58.07Zm-8.66,85.53,21.44-67.08,21.22,67.08Z"/><path d="M212.59,95.12a57.27,57.27,0,0,0-4.92-47.05,58,58,0,0,0-62.4-27.79A57.29,57.29,0,0,0,102.06,1,57.94,57.94,0,0,0,46.79,41.14,57.31,57.31,0,0,0,8.5,68.93a58,58,0,0,0,7.13,67.94,57.31,57.31,0,0,0,4.92,47A58,58,0,0,0,83,211.72,57.31,57.31,0,0,0,126.16,231a57.94,57.94,0,0,0,55.27-40.14,57.3,57.3,0,0,0,38.28-27.79A57.92,57.92,0,0,0,212.59,95.12ZM126.16,216a42.93,42.93,0,0,1-27.58-10c.34-.19,1-.52,1.38-.77l45.8-26.44a7.43,7.43,0,0,0,3.76-6.51V107.7l19.35,11.17a.67.67,0,0,1,.38.54v53.45A43.14,43.14,0,0,1,126.16,216ZM33.57,176.46a43,43,0,0,1-5.15-28.88c.34.21.94.57,1.36.81l45.81,26.45a7.44,7.44,0,0,0,7.52,0L139,142.52v22.34a.67.67,0,0,1-.27.6L92.43,192.18a43.14,43.14,0,0,1-58.86-15.77Zm-12-100A42.92,42.92,0,0,1,44,57.56V112a7.45,7.45,0,0,0,3.76,6.51l55.9,32.28L84.24,162a.68.68,0,0,1-.65.06L37.3,135.33A43.13,43.13,0,0,1,21.53,76.46Zm159,37-55.9-32.28L144,70a.69.69,0,0,1,.65-.06l46.29,26.73a43.1,43.1,0,0,1-6.66,77.76V120a7.44,7.44,0,0,0-3.74-6.54Zm19.27-29c-.34-.21-.94-.57-1.36-.81L152.67,57.2a7.44,7.44,0,0,0-7.52,0L89.25,89.47V67.14a.73.73,0,0,1,.28-.6l46.29-26.72a43.1,43.1,0,0,1,64,44.65ZM78.7,124.3,59.34,113.13a.73.73,0,0,1-.37-.54V59.14A43.09,43.09,0,0,1,129.64,26c-.34.19-.95.52-1.38.77L82.46,53.21a7.45,7.45,0,0,0-3.76,6.51Zm10.51-22.67,24.9-14.38L139,101.63v28.74L114.1,144.75,89.2,130.37Z"/></svg></a>
    </div>
    <div class="col-12 col-sm-4 col-md-3 col-xl-3 mb-1">
      <div>Company</div>
      <hr class="mt-1/12 mb-1/6">
      <ul class="multicol-2 multicol-sm-1">
        <li><a class="faded" href="/api/">API</a></li>
        <li><a class="faded" href="/projects/">Projects</a></li>
        <li><a class="faded" href="/blog/">Blog</a></li>
        <li><a class="faded" href="/about/">About</a></li>
        <li><a class="faded" href="/jobs/">Jobs</a></li>
      </ul>
    </div>
    <div class="col-6 col-sm-4 col-md-3 col-xl-3 mb-1">
      <div>Latest</div>
      <hr class="mt-1/12 mb-1/6">
      <ul>
        <li><a class="faded" href="/blog/tags/research/">Research</a></li>
        <li><a class="faded" href="/blog/tags/announcements/">Announcements</a></li>
        <li><a class="faded" href="/blog/tags/events/">Events</a></li>
        <li><a class="faded" href="/blog/tags/milestones/">Milestones</a></li>
      </ul>
    </div>
    <div class="col-6 col-sm-4 col-md-3 col-xl-3 mb-1">
      <div>Resources</div>
      <hr class="mt-1/12 mb-1/6">
      <ul>
        <li><a class="faded" href="/newsroom/">Newsroom</a></li>
        <li><a class="faded" href="/timeline/">Timeline</a></li>
        <li><a class="faded" href="/papers/">Papers</a></li>
        <li><a class="faded" href="/charter/">Charter</a></li>
      </ul>
    </div>
  </div>
</footer>
  <script type="text/javascript" src="/assets/scripts/main.js?v=ec60cd2442"></script>
  
  <script>
// toggle VQ-VAE text and image
var toggle = function (id, classToAdd, shouldSwap) {
  var el = document.getElementById(id);
  if (!el) return;

  if (shouldSwap) {
    if (el.classList.contains(classToAdd)) return;
    el.classList.add(classToAdd);
  } else {
    if (el.classList.contains(classToAdd)) el.classList.remove(classToAdd);
  }
};

var initPlayVQVAE = function () {

  var audioPath = "https://cdn.openai.com/jukebox/assets/samples/";
  var audioObjects = [
    new Audio(audioPath + "audio-0.wav"),
    new Audio(audioPath + "audio-1.wav"),
    new Audio(audioPath + "audio-2.wav"),
    new Audio(audioPath + "audio-3.wav"),
    new Audio(audioPath + "audio-novel.wav"),
  ];
  var audioElements = [
    document.getElementById('audio-0'),
    document.getElementById('audio-1'),
    document.getElementById('audio-2'),
    document.getElementById('audio-3'),
    document.getElementById('audio-novel'),
  ];
  audioObjects.forEach(function (o) {
    o.volume = 0.1 // set volume
  });
  
  function playAudio(n) {
    audioObjects.forEach(function (o) {
      o.pause();
      o.currentTime = 0;
    });
    audioObjects[n].play();
    // setTimeout(function () {
    //   audioObjects[n].pause();
    //   audioObjects[n].currentTime = 0;
    // }, 5000);
  }

  audioElements.forEach(function (el, n) {
    if (!el) return;
    el.addEventListener('click', function () {
      playAudio(n);
    });
  })
};

var initGroupedAuthors = function () {
  var parent = document.querySelector('.js-post-footer-authors-list');
  if (!parent) return;

  var authors = parent.children;
  authors = Array.prototype.slice.call(authors); // convert from HTMLCollection to array first

  var groups = [
    {label: '(Equal contributors)', authorIndices: [0,1,2]},
    {label: '', authorIndices: [3,4,5]}
  ];

  // reattach the sorted elements, conditionally
  groups.forEach(function (o, i) {
    var g = document.createElement('div');
    if (i != 0) g.className = 'mt-0.5';
    parent.appendChild(g);
    o.authorIndices.forEach(function (j) {
      if (!authors[j]) return;
      var c = authors[j].cloneNode(true);
      g.appendChild(c);
    });

    if (!o.label) return;
    var note = document.createElement('div');
    note.className = 'xsmall-caps color-fg-40 mt-0.25';
    note.innerHTML = o.label;
    parent.appendChild(note);
  });

  // remove original, ungrouped authors
  authors.forEach(function (a) {
    parent.removeChild(a);
  });
};

document.addEventListener('DOMContentLoaded', function () {
  initPlayVQVAE();
  initGroupedAuthors();
});
</script>

<script type="module">

import {Runtime, Inspector, Library} from "https://unpkg.com/@observablehq/runtime@4.5.0/dist/runtime.js";

// import notebook from "https://cdn.openai.com/musenet/visualization/c8b2460ddacd0978%40401.js";
import notebook_samples from "https://api.observablehq.com/d/af5865cec68879b7.js?v=3";
import notebook_vqvae from "https://api.observablehq.com/d/ff228369804ecc28.js?v=3";
import notebook_tsne from "https://api.observablehq.com/d/9549dd9d782c6b22.js?v=3";

const customWidth = function (selector) {
  return (new Library).Generators.observe(function(change) {
    var width = change(document.querySelector(selector).clientWidth);
    function resized() {
      var w = document.querySelector(selector).clientWidth;
      if (w !== width) change(width = w);
    }
    window.addEventListener("resize", resized);
    return function() {
      window.removeEventListener("resize", resized);
    };
  });
};

const samples_renders = {
  "tabbedInteractive": "#samples"
};
new Runtime(Object.assign(new Library, {width: customWidth("#samples")})).module(notebook_samples, name => {
  const selector = samples_renders[name];
  if (selector) { // key exists
    return new Inspector(document.querySelector(selector));
  } else {
    return true;
  }
});

const vqvae_renders = {
  "overview3": "#overview-3",
};
const runtime = new Runtime(Object.assign(new Library)).module(notebook_vqvae, name => {
  const selector = vqvae_renders[name];
  if (selector) { // key exists
    return new Inspector(document.querySelector(selector));
  } else {
    return true;
  }
});

const tsne_renders = {
  "inlinecss": "#tsne-styles",
  "chart": "#tsne",
};
new Runtime(Object.assign(new Library, {width: customWidth("#tsne")})).module(notebook_tsne, name => {
  const selector = tsne_renders[name];
  if (selector) { // key exists
    return new Inspector(document.querySelector(selector));
  } else {
    return true;
  }
});

</script>
</body>
</html>
